[MS4W-Users] version 3.1.0

Björn Danielsson bjorn.danielsson at falubo.se
Mon Oct 5 11:40:12 EDT 2015

Thanks for answering so soon,

I have done this concerning Oracle.
1 Swap libmap.dll
2 uncomment php_oci8_11g.dll in the ini-file. (Why should this extension be 
present in the ini-file if it should not be uncommented? )

Result: php_mapscript.dll is not loaded.

If php_oci8_11g.dll is commented -> php_mapscript.dll is loaded. Which makes 
me believe that php_oci8_11g.dll has some impact here.

As I tried to say in the mail ( I know I'm getting tired, it is pitch dark 
outside here now and I am soon crossed eyed ) let's start with 
php_mbstring.dll and have that dll included without errors in error.log.


-----Original Message-----
From: Jeff McKenna <jmckenna at gatewaygeomatics.com>
To: ms4w-users at lists.ms4w.com
Date: Mon, 5 Oct 2015 12:15:18 -0300
Subject: Re: [MS4W-Users] version 3.1.0

Hi Björn,

Regarding setting up the Oracle plugin for MapServer, please follow the
steps in your local README, or here:

You will notice that there is no mention of "php_oci8_11g.php" in those
steps to enable the Oracle plugin for MapServer, I am not sure where you
saw that mentioned for version 3.1.0

It could be that you are requesting an enhancement for the PHP build of
MS4W 3.1.0? It could be that you need a new extension built for PHP? (I
have no idea yet though) I am not sure what you are requesting, but if
that is what you need you can always file your enhancements on the
Tracker at http://www.ms4w.com/trac/

I need more information from you first, to understand what you need to
do.  Are you saying that there is a PHP extension missing?  I am not
sure.  Maybe just following the steps in the README (only those steps),
and then test phpmapscript (don't uncomment anything else), does that
work?  If yes, that's great, PHPMapScript is working on your server.
Then, I am not sure what you need after that.  Please explain.


Jeff McKenna
MapServer Consulting and Training Services

On 2015-10-05 11:51 AM, Björn Danielsson wrote:
> Hi,
> I am trying to migrate from 3.0.6 to 3.1.1 and have encountered issues.
> It started with Oracle. I swapped libmap.dll as instructed and
> uncommented php_oci8_11g.php in the ini-file ( like for version 3.0.6 )
> and restarted Apache. The same Oracle/instantclient_11_2 as before.
> And php_mapserver.dll did not load.
> I commented php_oci8_11g.php and swapped back libmap.dll.
> Php_mapserver.dll loaded.
> A look in error.log showed a lot of -  PHP Warning:  PHP Startup:  in
> Unknown on line 0:
> I commented all extensions and started uncomment them one by one from
> the top. At php_mbstring.dll the errors started to show up in error.log.
> Php_mbstring.dll obviously calls modules that do not exist.
> I stopped testing here. Something seems to be missing. But what?
> In 3.1.0 the includes in Path does not include 'C:'. I have not changed
> the Path in my computer so the includes start with C:\ms4w... instead of
> \ms4w.... That is the only difference between the 3.0.6-installation and
> the 3.1.0-installation. I do not believe that this is the issue because
> php_mapscript.dll, php_curl.dll and other dlls are found in /php/ext.
> This happened in a Windows7 test computer with the plan to be installed
> in a prod computer under Windows Server 2012R2.
> The Mapserver graphics in 3.1.0 looks better than that in 3.0.6 so
> hopefully we can migrate to 3.1.0.
> I have tried everything my phantasy has come up with and am still at loss.
> Perhaps someone with a broader phantasy then mine knows what is going on.
> On the Internet someone mentioned that PostGis perhaps can be the
> villain. I don't know.
> First I would like to get rid of the error messages in error.log and
> then include php_oci8_11g.dll.

MS4W-Users mailing list
MS4W-Users at lists.ms4w.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ms4w.com/mailman/private/ms4w-users/attachments/20151005/7947b261/attachment.html>

More information about the MS4W-Users mailing list